Welcome to Catch Up

cancel
Showing results for 
Search instead for 
Did you mean: 
Need help?

Catch Up problems

SOLVED
31 REPLIES 31
New poster

Re: Catch Up problems

I am having the same problem, did you eventually find a solution?

Anime

Re: Catch Up problems

They have had problems since their major system update. Has anybody checked your signal strength? If Catchup starts downloading at the support centre ( can take up to 48hrs), then the problem could be with your installation. Might be worth your while recalling the original installer.

Good Luck

New poster

Re: Catch Up problems

I bought explorer in August and catchup has never worked. There is a message that says Dstv Catchup is not available in this country. No one at Dstv could help resolve this to-date

New poster

Re: Catch Up problems

Thank you Marthie, i will take it tomorrow

Anime

Re: Catch Up problems

Best solution is to take your decoder to Multichoice. They actually swopped out mine ( fortunately I have insurance). Both were swopped the p2 pvr as well as the Explora and all is fine now.

New poster

Re: Catch Up problems

My catch up is missing most of the shows and channels. Please help

New poster

Re: Catch Up problems

Has your issue been resolved? I'm having the same problem.

Anime

Re: Catch Up problems

Hi Grace, your solution also does not work, the message pops up as soon as you select CU from the menu, See my post

Anime

Re: Catch Up problems

Eventually spoke to MC. It all has to do with their upgrade, funny I can get catchup through DSTV NOW on my IPAD and laptop, but ni\ot through my EXPLORA, guess the pre upgrade testing was not so hot!!!

I am going to take up the issue of refund for services NOT rendered, watch this space

Anime

Re: Catch Up problems

SORRY but not solved. My message alternates between:

Catchup not available in your country, and

 "We are downloading the latest movies,series and more to your DStv Explora.Check back soon to see what we have lined up for you."

 

This has been going on for at least 10 days. I assumed it was due to the upgrade but 10 days? Really?

I had error code, which I cleared then rebooted twice, no joy!