Welcome to EXPLORA

Showing results for 
Search instead for 
Did you mean: 
Need help?

New Explora software updates


Re: New software update(s) - Oct '18 - Feb '19

@Jan-Hornmentioned these updates;


"2A Diana 45/2

3A Diana  4/2"


I've now got 99/2 on my Explora 1.


Please note that the nickname "Diana" (all Exploras) won't necessarily only be used for these updates.

Although MC do seem to be using them more as one-for-one type labels these days...


Re: New software update(s) - Oct '18 - Feb '19

More terrible programming (coding) efforts found;


Search \ Series \ New Seasons \ TV Guide

1. Search says it's complete, but the total count continues to increase for ages beyond that. (Re reproducing it - I may have moved around the various sections first.)

2. You can't navigate through the list until the search is really completed, it keeps throwing one back to the first entry on page 1 each time the list increases.


Really troubling. Managers need to pass these endless forum reports from everyone right to the top, else this company is heading for disaster. Won't be long before most stop bothering due to lack of progress and ever worsening efforts.

Doin' it 4 Tv

Re: New software update(s) - Oct '18 - Feb '19


We have tested this and it is 100% reproducible.  I’ve logged a defect for prioritization to be planned for fixing in upcoming releases.



Re: New software update(s) - Oct '18 - Feb '19

Another Showmax s/w bug;


This one has happened to me a few times.

I start watching an episode of a series, then immediately rewind and pause, waiting for some of it to first buffer.

Then I change the Aspect Ratio with the ARC button from Pillarbox to Letterbox (due to the one TV that this is being watched on.)


When the ARC setting disappears off screen, I'm shot back to the entry screen of the series, as if I had exited a couple of steps... but I haven't and the streaming continues as if nothing has happened. Simply exiting further takes me back to the full screen of the paused streamed episode.


Is there maybe a second team developing the Showmax s/w? It seems better in some respects, but much of the recent issues point to this "team", or effort.


(Not available...)


Re: New software update(s) - Oct / Nov '18

The above "Just Added" method sometimes only works on second attempt for me.




Getting CU+ to populate my "You're watching" list - tried again with The Americans this morning, it does work if using Watch Now but not if using Download. In my case using SD, and first tried it successfully in the Featured \ New And Returning Shows section.




Not related to the thread, but maybe useful for those who read and post here (tech minded) - this forum does allow access via a VPN (Virtual Private Network). Great for personal privacy and security, and surprising considering the other geo-blocking MC involves itself with - well done, this one you deserve kudos for MC.


Re: New software update(s) - Oct / Nov '18

Possible temp. fix for blank-CU-section bug (BTW, MC don't currently choose to call it a bug) - please would others let us know if this works for them or not.


When you get the "blank" CU section screen, press the blue DStv button (Just Added section).

Wait in that section until the thumbnail pics for Showmax (SM) populate.

Now try returning to the CU section.


If this is doing what it seems to for me, it then shows further confusion between CU and SM software routines.

Also interesting that older software builds couldn't access the Just Added section.



(Not necessarily available for discussion, which is now the norm...)

Red Carpet

Re: New software update(s) - Oct / Nov '18

Another major mess up with the sw or with the authentication data?

Octo LNB; 2 by 2x4 MS; 2 by ES 5-2; Dedicated PSU for LNB, ES's, MS's; HD PVR 4P x 2; Explora 1; DSD 660; FSM

Re: New software update(s) - Oct / Nov '18

I've never gotten this error message before. If I press DStv button I get cu and box office no showmax, if I press showmax button I get attached image 


Re: New software update(s) - Oct / Nov '18

I experienced a very troubling software muddle this morning on L97. Hopefully it's a clue as to why the software has become so confused with the VOD services.


I was in the Showmax app, looking at Series \ Drama.

I changed my titles order from "Z-A" to "Recently Released".

This resulted in the DStv "You're-Watching" screen being displayed instead, with the Showmax title etc. still at the top of the screen.


I pressed the right arrow key to try move to the next section in the "Showmax" app, or wherever I was now... , and then found myself properly back in the Showmax app as if nothing had happened, with no further sign of any DStv items.


Extreme to say the least MC, and the only reason I've added more to the thread.

The dev. team are clearly capable of better given their reasonable Explora history, let's hope they'll be allowed what they need to get back there again now... this certainly ought to be the last straw.......


Re: New software update(s) - Oct / Nov '18

@Grace_DStv1 wrote:

@Optimistand @JeanPThe random disappearing of CU titles, this was addressed with Architectural Forum for some improvements. This happens when the user access CU while there’s a catalog update at the same time. The screen will go blank and show the generic CU message while processing the new acquired catalog.  The user will need to wait +-30 seconds for the process to complete. If the user doesn’t exit the screen while this is showing, it will not automatically refresh, thus re-launching of the CU screen will be required after 30 seconds at most. 

@Grace_DStv1 - apologies but the architectural team is going to have to come up with a better explanation on this or admit that there is a problem. For 5 years this never happened (except after a reboot) and catalog updates were always taking place. Now there is not a day that goes by that I don't get this and there is no way I always happen to try CU at the time an update occurs. It pretty much happens EVERY time after CU hasn't been accessed for a while.


This only started happen a few software updates ago so clearly something was changed that causes this, and it wasn't a change for the better so it needs to be reversed. This is a bug and nothing else.



Octo-LNB to 2 x 5.2 switches. Explora1 (Prim) & HDPVR 2P (Sec), Samsung 55" UA55F8500 Smart 3D LED TV, HDMI picture & audio via Onkyo TX-NR626
receiver. Explora2 in bedroom, HDMI picture & audio to Samsung 32" UA32F5500 Smart LED TV. 100Mbps M-Web fibre (OpenServe).