Welcome to EXPLORA

cancel
Showing results for 
Search instead for 
Did you mean: 
Need help?

Some failed recordings caused by faulty EPG system

3 REPLIES 3
Showmaxed

Re: Some failed recordings caused by faulty EPG system

My change to a 136 MR option (edit above) worked fine of course, but there were more revelations so here's a further summary for MC to learn from. Sorry for the boring thread...

 

An EBR recording on 120 in the early hours did work, even though that channel is also via the uplink farm - so possibly not related to that after all, or an isolated incident there, or was already fixed.

 

140 recording outcome;

The recording has survived. It did have an exclamation mark. The error report has survived.

However - there was never any attempt to reschedule a recording for it.

This suggests another Explora software issue in this case. I suspect that code re the late-start reporting is less tolerant than the code re the replace-file function, if they are separate routines, and if so this is a poor example of some combination of the software engineering, development management and the analysis - using universal parameters is often essential.

Showmaxed

Re: Some failed recordings caused by faulty EPG system

Nope, this nightmare is not done with me yet...

 

1. I later examined the failed recordings list again - the 136 failure report has since vanished!! So more confusion we all had about that factor is now "explained"...

 

2. That list now instead has a report with the same wording re the 140 movie, but I'm fairly sure it's just due to starting it a few seconds late and that all is behaving normally there. If I'm wrong there will be another post soon (but I won't report if it rescheduled itself which I am expecting, and which I'll then delete).

 

3. In the first post I mentioned trying to redo the 136 recording schedule in the EPG - my efforts were manual but it wasn't a "Manual Recording", it was an attempt to get the SBR going again.

 

 

My biggest interest is why only some channels are affected by the false time bug sometimes. Maybe this is the less-than-interested Spanish uplink farm again?

If you want more of these reports MC you should give us real tech feedback, and maybe think about paying more attention to your often neglected fieldtrials program with the public as well.

 

EDIT: Have changed my now later 136 events to MRs.

Showmaxed

Re: Some failed recordings caused by faulty EPG system

More than another edit needed to finish this off;

 

The 136 "recording" wouldn't end itself, or manually - it reported minus-figures of remaining time to go when attempting to stop it manually.

I did a warm reboot.

Was just in time for the 140 event but it didn't start (there was no time to check details why), but the 136 event had not only "stopped", it had vanished from the Playlist... which explains a lot now...

 

I started the 140 event manually from the i-plate, that attempt appears fine.

 

There's been some good intentions mentioned by MC a few times recently, let's hope they end up a case of action speaking louder than words.

 

Edits finished.

Showmaxed

Some failed recordings caused by faulty EPG system

The following report is only being made due to the info breakthrough it appears to offer re the odd failed recordings without reason that are sometimes reported here.

Not all info mentioned may be related to the outcomes.

I will not be available for any discussion, MC don't pay or reward outsiders for useful tips.

 

 

The Explora 1 was put on ch. 202 early this morning and not moved from there until after the cricket sometime after 17:30. This unbroken duration on a sport channel is unusual, but I doubt related.

 

From there I went to 136. Before the i-Plate could be auto removed, I noticed that the listed times quickly changed from normal to an earlier period starting sometime after 10:00. This is known buggy behaviour seen by many Forumites. Bringing up the i-Plate again I saw that the current time displayed itself was still correct and it remained so throughout.

 

Many times during these events I toggled between 103, 106, 136, and 202 to try understand and correct the behaviour. Only 136 was ever, and always, in error.

I next tried a soft (warm) reboot. This resulted in 106 showing "Searching" instead of "Watching", so after some examination I did a hard (cold) reboot - this time all appeared back to normal.

BTW, after each reboot I allowed time for the EPG to repopulate first.

 

Next I tried visiting 136 again. Same problem, and this time it removed my SBR recording planned for there @19:20 and a EBR for a movie on 140 @  20:00.

There were no errors or rescheduled listings so in the EPG I tried to manually set a recording for the 136 event. This resulted in an error claiming there was already a recording at that time, and the details claimed it was the missing recording schedule.

 

So, I tried a soft reboot again - that was ok this time, and the 136 event was back in the schedule. I manually then tried to redo the 140 event, which worked. I never visited viewing 136 again.

 

The 136 event started recording on time.

At this point I decided to remove a reminder I had for a 21:30 movie on 103.

1. The moment I did that, suddenly a 136 SBR-triggered repeat recording for the same episode later tonight appeared, even though the currently recording one remained listed in the schedule.

2. It was still listed in my Playlist as well, evidently still recording as it was meant to.

3. An error about this same, still in action recording is now reported as having failed - it says "Unable to record". Unbelievable!!

4. I will only remove the "2nd attempt" item from the list after the current one has finished its task.

 

 

This is beyond tolerable and normal bug behaviour MC, if you don't wake up enough your systems and staff without responsibility are going to do terrible damage.

I wish you all the best with it.

 

(This thread may be edited in the next hour for accuracy.)

Edit 1 - point 3 - improved wording to better explain the error.

Edit 2 - outcome of first recording - (info will be added here)

No further edits will be necessary.